OpenAL aus Versehen gelöscht / Kein Ton mehr Thema ist als GELÖST markiert

Fragen oder Probleme bezüglich der technischen Seite von WCS: The Darkest Dawn (Deutsch)

Moderatoren: Kalumet, Joker, MajorSpawn

Forumsregeln
  • Bitte das Präfix [WCS] verwenden, wenn das englische original Wing Commander Saga gemeint ist. Bei unserer deutschen Version ist kein Präfix nötig.
  • Bei technischen Problemen bitte eine vollständige Inventur mit DBST durchführen und das erzeugte Support Archiv (WCS_SupportTool_Data_{name}.7z) dem Beitrag anhängen.
  • Bei Fehler-Berichten bitte beachten: Fehler melden - Richtlinie.
In diesem Unterforum ist die Support Erweiterung aktiv:
  • Jeder Themenstarter kann eine Antwort als Lösung markieren. Diese grüne Markierung wird dann dauerhaft beim betreffenden Beitrag angezeigt sowie in der Themenübersicht.
  • Jede grüne Markierung kann sowohl in der Themenübersicht, als auch im Thema ganz oben angeklickt werden, wodurch direkt der Beitrag mit der Lösung aufgerufen wird.
  • Wurde eine Markierung falsch oder versehentlich gesetzt, bitte einen Moderator ansprechen.
Benutzeravatar
legionnaire
Chief Petty Officer
Chief Petty Officer
Beiträge: 88
Registriert: Sa 30. Apr 2016, 00:51
Wohnort: Mannheim

OpenAL aus Versehen gelöscht / Kein Ton mehr

Beitrag von legionnaire » Fr 6. Mai 2016, 12:56

Hallo Euch Allen,
ich schon wieder. hatte heute früh ein Problem mit dem Stratmenu WIN10, ales behoben, doch in der Eile Open AL.dll gelöscht. Kann ich das wieder richten, oder muss ich WCSD neu installieren?? So ist es, wenn man nicht aufpasst, hatte nicht geahnt, dass ich open AL.dll brauche
Gruß Gerd

Benutzeravatar
Luke
Developer
Developer
Germany
Beiträge: 3074
Registriert: Do 14. Aug 2014, 15:18
Wohnort: Sourcecode
Team-Rang: Entwickler
Fachgebiet: Implementierung
Spezialisierung: Programmierung

Re: Probleme bei der Installation der Updates

Beitrag von Luke » Fr 6. Mai 2016, 13:34

legionnaire hat geschrieben:ich schon wieder. hatte heute früh ein Problem mit dem Stratmenu WIN10, ales behoben, doch in der Eile Open AL.dll gelöscht. Kann ich das wieder richten, oder muss ich WCSD neu installieren??
Schau in deinen WCS Ordner, dort findet du oalinst.exe mit dem du OpenAL neu installieren kannst. OpenAL wird für WCS zwingend benötigt.

WCS steuert übrigens sogar 4 Boxen an, so kann man z.B. Explosionen genau ausmachen. Auch wenn das natürlich im All kompletter Nonsens ist. ;)

Nachtrag: nach der erneuten Installation von OpenAL muss im WCS Launcher im Bereich "Audio" der Punkt "Audio Device" auf "Generic Software" eingestellt sein.
Tools: Setup ZIP Check & UnZip / DBST / Pilot Manager / VPT ...und andere
HowTo's: Joystick: Schub und Ruder (Twist) definieren ...und andere
Projekte: Deutsch-Mod / WCS+

"Det jeht nich', da is' keen Platz!"

Benutzeravatar
legionnaire
Chief Petty Officer
Chief Petty Officer
Beiträge: 88
Registriert: Sa 30. Apr 2016, 00:51
Wohnort: Mannheim

Re: Probleme bei der Installation der Updates

Beitrag von legionnaire » Fr 6. Mai 2016, 16:29

Hej Luke,
wieder mal Rettung in Sicht, Danke.
Gruß Gerd

Benutzeravatar
Luke
Developer
Developer
Germany
Beiträge: 3074
Registriert: Do 14. Aug 2014, 15:18
Wohnort: Sourcecode
Team-Rang: Entwickler
Fachgebiet: Implementierung
Spezialisierung: Programmierung

Re: Probleme bei der Installation der Updates

Beitrag von Luke » Fr 6. Mai 2016, 19:11

Und zum besseren Verständnis, hier die Erklärung zu Wikipedia OpenAL.
Tools: Setup ZIP Check & UnZip / DBST / Pilot Manager / VPT ...und andere
HowTo's: Joystick: Schub und Ruder (Twist) definieren ...und andere
Projekte: Deutsch-Mod / WCS+

"Det jeht nich', da is' keen Platz!"

Benutzeravatar
Kalumet
Moderator
Moderator
Germany
Beiträge: 881
Registriert: So 17. Aug 2014, 16:44
Wohnort: Bruchsal
Team-Rang: Chief Senior Tester
Fachgebiet: Betatest
Spezialisierung: Öffentlichkeitsarbeit

Re: Probleme bei der Installation der Updates

Beitrag von Kalumet » Fr 6. Mai 2016, 21:18

Luke hat geschrieben:Und zum besseren Verständnis, hier die Erklärung zu Wikipedia OpenAL.
:eek: :runaway:
Gruß Kalumet
Bild

Benutzeravatar
legionnaire
Chief Petty Officer
Chief Petty Officer
Beiträge: 88
Registriert: Sa 30. Apr 2016, 00:51
Wohnort: Mannheim

Re: Probleme bei der Installation der Updates

Beitrag von legionnaire » Sa 7. Mai 2016, 08:24

Hej Jungs,
nun läuft alles, was ich ausprobiert habe. Der Ton ist aber nicht mehr vorhanden, weder Sprache noch Musik ist zu hören. Die Einstellungen des Rechnerns sind ok. Bei den Einstellungen des Spiels kann ich Musiklautstärke verstellen, wenn ich das bei der Sprache versuche, dann stürzt das Tel ab. Lässt soch aber sofort wieder neu laden. Vielleicht habt Ihr mir auch dazu einen Tip, was heisst hier vielleicht. Wie ich Euch einschätze ganz bestimmt :)
Gruß Gerd

Benutzeravatar
Luke
Developer
Developer
Germany
Beiträge: 3074
Registriert: Do 14. Aug 2014, 15:18
Wohnort: Sourcecode
Team-Rang: Entwickler
Fachgebiet: Implementierung
Spezialisierung: Programmierung

Re: OpenAL

Beitrag von Luke » Sa 7. Mai 2016, 11:20

Moin Gerd

Da das mit deinem ursprünglichen Problem nichts mehr zu tun hat, Thema aufgeteilt.
legionnaire hat geschrieben: Bei den Einstellungen des Spiels kann ich Musiklautstärke verstellen, wenn ich das bei der Sprache versuche, dann stürzt das Tel ab.
Ich brauche erneut die DBST Daten, bitte wieder vollständige Inventur.
Tools: Setup ZIP Check & UnZip / DBST / Pilot Manager / VPT ...und andere
HowTo's: Joystick: Schub und Ruder (Twist) definieren ...und andere
Projekte: Deutsch-Mod / WCS+

"Det jeht nich', da is' keen Platz!"

Benutzeravatar
legionnaire
Chief Petty Officer
Chief Petty Officer
Beiträge: 88
Registriert: Sa 30. Apr 2016, 00:51
Wohnort: Mannheim

Re: OpenAL

Beitrag von legionnaire » Sa 7. Mai 2016, 12:32

Hej Luke,
zunächst mal herzlichen Dank für die schnelle Antwort. Ich kenne nur noch ein Forum, wo das genau so schnell geht, das von DSO.
Als Anhang die Datei und ich hoffe, Du findest was, womit dem Ausfall ein Ende gesetzt wird. Wie Du sehen kannst, habe ich Wing Commander noch nicht im Griff, aber gut ding braucht Zeit :lol:
Gruß Gerd
Zuletzt geändert von Luke am Sa 7. Mai 2016, 12:37, insgesamt 1-mal geändert.
Grund: Anhang gelöscht

Benutzeravatar
Luke
Developer
Developer
Germany
Beiträge: 3074
Registriert: Do 14. Aug 2014, 15:18
Wohnort: Sourcecode
Team-Rang: Entwickler
Fachgebiet: Implementierung
Spezialisierung: Programmierung

Re: OpenAL

Beitrag von Luke » Sa 7. Mai 2016, 12:36

Nunja, je nachdem wer hier gerade unterwegs ist, hängt natürlich auch von unserem Beruf und Privatleben ab. ;) DSO kennen/haben auch einige bei uns, mich eingeschlossen.
Tools: Setup ZIP Check & UnZip / DBST / Pilot Manager / VPT ...und andere
HowTo's: Joystick: Schub und Ruder (Twist) definieren ...und andere
Projekte: Deutsch-Mod / WCS+

"Det jeht nich', da is' keen Platz!"

Benutzeravatar
Luke
Developer
Developer
Germany
Beiträge: 3074
Registriert: Do 14. Aug 2014, 15:18
Wohnort: Sourcecode
Team-Rang: Entwickler
Fachgebiet: Implementierung
Spezialisierung: Programmierung

Re: OpenAL

Beitrag von Luke » Sa 7. Mai 2016, 12:53

  1. Starte den WCS Launcher und klicke auf "Audio".
  2. Stell bitte "Generic Software" ein.
  3. Speichere und starte WCS mit  Run .
Tools: Setup ZIP Check & UnZip / DBST / Pilot Manager / VPT ...und andere
HowTo's: Joystick: Schub und Ruder (Twist) definieren ...und andere
Projekte: Deutsch-Mod / WCS+

"Det jeht nich', da is' keen Platz!"

Benutzeravatar
legionnaire
Chief Petty Officer
Chief Petty Officer
Beiträge: 88
Registriert: Sa 30. Apr 2016, 00:51
Wohnort: Mannheim

Re: OpenAL aus Versehen gelöscht / Kein Ton mehr

Beitrag von legionnaire » Sa 7. Mai 2016, 13:50

Hej Luke,
passt.........alles wieder ok. Bedanke mich herzlich, daruf hätte ich ja auch achten können.
Natürlich hängt es davon ab, wie der berufliche und private Status ist, um heir agieren zu können. Dennoch einsame Spitze hier und DSO, ich habe dort auch den Link zu Euch gefunden.
Schönes WE und nochmals Danke.
Gruß Gerd

Benutzeravatar
Luke
Developer
Developer
Germany
Beiträge: 3074
Registriert: Do 14. Aug 2014, 15:18
Wohnort: Sourcecode
Team-Rang: Entwickler
Fachgebiet: Implementierung
Spezialisierung: Programmierung

Re: OpenAL aus Versehen gelöscht / Kein Ton mehr

Beitrag von Luke » Sa 7. Mai 2016, 14:05

Gerne.

Könntest du einen Link posten bez. DSO wo auf WCSD verweisen wird? Wäre auch für uns interessant. ;)
Tools: Setup ZIP Check & UnZip / DBST / Pilot Manager / VPT ...und andere
HowTo's: Joystick: Schub und Ruder (Twist) definieren ...und andere
Projekte: Deutsch-Mod / WCS+

"Det jeht nich', da is' keen Platz!"

Benutzeravatar
legionnaire
Chief Petty Officer
Chief Petty Officer
Beiträge: 88
Registriert: Sa 30. Apr 2016, 00:51
Wohnort: Mannheim

Re: OpenAL aus Versehen gelöscht / Kein Ton mehr

Beitrag von legionnaire » Sa 7. Mai 2016, 18:47

Hej, hej Luke,
gerne mache ich das. Habe da noch eine Frage, wo finde ich eine Möglichkeit die Steuerung des Schiffes, der Waffen etc. auszudrucken? So, dass ich das mal pauken kann, ich habe keine Ahnung mehr und eiere recht ordentlich herum :lol:

http://www.supernature-forum.de/pc-und- ... -dawn.html

Gruß Gerd

Benutzeravatar
Luke
Developer
Developer
Germany
Beiträge: 3074
Registriert: Do 14. Aug 2014, 15:18
Wohnort: Sourcecode
Team-Rang: Entwickler
Fachgebiet: Implementierung
Spezialisierung: Programmierung

Re: OpenAL aus Versehen gelöscht / Kein Ton mehr

Beitrag von Luke » Sa 7. Mai 2016, 18:50

Ach im Supernature Forum? Ok, in dem Thema bin ich selbst vertreten. ;)
legionnaire hat geschrieben: Habe da noch eine Frage, wo finde ich eine Möglichkeit die Steuerung des Schiffes, der Waffen etc. auszudrucken? So, dass ich das mal pauken kann, ich habe keine Ahnung mehr und eiere recht ordentlich herum
Hier. Beachte dabei bitte Kalumets Tipp im zweiten Beitrag.
Tools: Setup ZIP Check & UnZip / DBST / Pilot Manager / VPT ...und andere
HowTo's: Joystick: Schub und Ruder (Twist) definieren ...und andere
Projekte: Deutsch-Mod / WCS+

"Det jeht nich', da is' keen Platz!"

Benutzeravatar
legionnaire
Chief Petty Officer
Chief Petty Officer
Beiträge: 88
Registriert: Sa 30. Apr 2016, 00:51
Wohnort: Mannheim

Re: OpenAL aus Versehen gelöscht / Kein Ton mehr

Beitrag von legionnaire » Sa 7. Mai 2016, 21:41

Hej Luke,
Danke herzlich für Deine Hilfe.
Schönes Rest-WE mit schönstem Wetter.
Gruß Gerd